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ShareScan: Apache Tomcat service cannot start (Troubleshooting)

The Apache Tomcat services for eCopy ShareScan fails to start. It also cannot be started manually. This prevents Web Client devices including the Simulator from being functional.

Cause:

Java version mismatch. Apache Tomcat requires Java, and any modification, update or alteration to the Java can cause a service failure making the Apache Tomcat server unable to run.

Solution:

  1. See ShareScan: Java requirements. Reinstall Java if required.
  2. Reboot the ShareScan server.
  3. If the Apache Tomcat service still fails to start, a repair on the ShareScan WebClient component may be required (in "Apps", Programs and Features", or "Add/Remove Programs")

If Apache Tomcat fails to start with the error "service-specific error code 1" or "servce-specific error code 0" it may be attempting to use a copy of Java that is no longer present or incompatible. Verify that the path used by Apache Tomcat to locate Java is correct.

  1. Open the registry to one of the following locations depending on the operating system:
    64-bit: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun 2.0\Tomcat[7|8]\Parameters\Java
    32-bit: HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Procrun 2.0\Tomcat[7|8]\Parameters\Java
  2. Locate the propety with the name "Jvm"
  3. Verify that the path matches the directory for the installed version of Java. Example: C:\Program Files (x86)\java\jre8\bin\client\jvm.dll