When installing SafeCom G4 520*10.239.1 with Windows Authentication Setup the login to SafeCom Administrator fails. Error: "Connection error. Login failed!"
Problem:
When installing SafeCom G4 520*10.239.1 with Windows Authentication Setup the login to SafeCom Administrator fails. Error: "Connection error. Login failed!"
SafeCom broadcast for the Server is working, databases are created properly.
However when doing a "Test Server" with SafeCom Administrator following is seen:
Connection job server ... failed!
Connection tracking server ... failed!
Connection money server ... failed!
Additional following error can be seen in the JobServerX.trc:
TLS InitNegotiate error: missing certificate ErrorCode -1
Cause:
When installing SafeCom G4 520*10 with "windows authentication" TLS encryption may not work.
If the TLS certificate is created by the SafeCom Pull or Push Port (running as SYSTEM) then the SafeCom Service (running as ) won't be able to use that certificate due to insufficient rights, because by default, only the owner and the SYSTEM account can access the private key of a certificate.
Solution:
In order to create a new TLS certificate please perform following steps:
- Stop the SafeCom Service
- Delete the following Key in the registry path: HKEY_LOCAL_MACHINE\SOFTWARE\SafeCom\SafeComG4\TLSCert.
- Start SafeCom Service again.
A new TLSCert key will be created with the proper value and will allow a successful login.
Alternatively please find attached script to perform these actions.
Attachments: