SafeCom Administrator shows "database failure (2)" when opening the device list (Troubleshooting)

SafeCom Administrator shows "database failure (2)" when opening the device list

Problem Statement:

scAdministrator shows "database failure (2)" when opening the device list.

The server trace shows inappropriate device properties when the request of CI_SET_DEVICE_INFO_REQUEST is being processed.

The SafeCom JobServer is intermittently crashing.

Cause:

Invalid data is inserted into scDeviceInfo table (field Supported features) that prevents Safecom Administrator from displaying the device list.

Solution:

Hotfix for this issue is available through Nuance Technial Support for G4 520*07 and G4 520*09.

Crashes are eliminated by the hotfix.

If the data records are containing invalid data then it has to be reset manually (although the device list is shown in scAdministrator).

Instructions will also be shared through Nuance Technical Support together with the Hotfix.

 

Link to original article