SafeCom Administrator - Error Exporting Tracking Data (Troubleshooting)

When using the SafeCom Administrator export Tracking function an error is being shown: General Failure (1)

Problem Statement:

When using the SafeCom Administrator export Tracking function an error is being shown: General Failure (1)

AdmGui.trc shows:

ExecuteTransaction: Received reply [TS_EXPORT_TRACKING_REPLY](5002) 

ExecuteTransaction: Catch: ExecuteTransaction: Status error [SC_FAILURE](1)

Cause:

When doing an export of the Tracking data a temp file is created in the SafeCom data folder, regardless of the path the export file would be saved.

If the data folder is invalid or the user running SafeCom Administrator has no write access to the SafeCom data folder then the error is being shown.

Within the TrackingServerXX.trc an error similar to following would be seen:

CTSUserContext::CreateTempFile, creating temporary file: "E:\Program Files\SafeCom\SafeComG4\data\tr1d5c_0002.tmp"

CTSUserContext::CreateTempFile, creating temporary file failed: 2, No such file or directory

CreateSchema: Could not create temporary schema file

Resolution:

The default path for the data folder would be "C:\Program Files\SafeCom\SafeComG4\data\", but actually can be defined different during the install or through the registry.

Make sure the user running SafeCom Administrator has write access to the specified SafeCom data folder.

If the path does not exist it needs to be corrected through the registry:

"HKEY_LOCAL_MACHINE\SOFTWARE\SafeCom\SafeComG4"

The Key "FilePath" needs to have a valid path which can be written by the user running SafeCom Administrator.

 

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