Invalid eCopy TCP header error message when attempting to add a Ricoh MFP in ShareScan (Troubleshooting)

An error message appears in the console when attempting to add an embedded Ricoh MFP to the ShareScan Administrator's console.

Problem:

An error message appears in the console when attempting to add an embedded Ricoh MFP to the ShareScan Administrator's console.

An error occurred while communicating with the Client.: Aficio MP 4001 (192.168.1.23) -- Invalid eCopy TCP Header. Error Occurred in AdminConsole System.Exception: An error occurred while communicating with the Client.: Aficio MP 4001 (172.24.170.191) -- Invalid eCopy TCP Header. ---> System.Exception: Invalid eCopy TCP Header.   at ShareScanAdminConsole.AdminConsoleForm.UpdateClientConfig(eCopyDeviceEx Device, Boolean updateXml, Int32 managerPort, String& responseXML, Boolean DeviceDeletion)   --- End of inner exception stack trace --- InnerException Level: 1 System.Exception Invalid eCopy TCP Header.

Cause:

This is because the ShareScan server version is 5.2 (or 5.1) and the embedded client software version is 5.4.x. The 5.4.x client software is not compatible with previous versions of the ShareScan software. To use the 5.4 client, you must first upgrade the ShareScan server to v5.4.

Workaround:

Use the 5.2 client instead to add Ricoh MFPs to a 5.2 (or 5.1) ShareScan server.

 

Link to original article